Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Email Notification Delays
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Apr 25, 2016 - 14:47 PDT
      Update
      We are still monitoring the recovery of the delayed email notifications. We will post another update once the queues have cleared.
      Posted Apr 25, 2016 - 14:21 PDT
      Update
      We are continuing to monitor the recovery of the delayed email notifications. We will post another update once the queues have cleared.
      Posted Apr 25, 2016 - 12:47 PDT
      Monitoring
      We are seeing a recovery of the delayed email notifications. We will continue to monitor as the queued notifications get delivered.
      Posted Apr 25, 2016 - 12:08 PDT
      Update
      We continue to work with our provider partners to resolve the email notification delays.
      Posted Apr 25, 2016 - 11:45 PDT
      Investigating
      We’re currently investigating an issue with delays in email notifications. Customers may experience delays in receiving emails from Twilio, such as triggers and password resets.
      Posted Apr 25, 2016 - 11:15 PDT
      This incident affected: DEVELOPER TOOLS (Console).