Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays and Failures to Multiple Networks over Multiple Countries in Africa
      Incident Report for Twilio
      Update
      We are continuing to experience SMS delivery delays to Multiple Networks and Countries in Africa. Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:

      - Tanzania: TTCL, Viettel
      - Mozambique: Vodacom
      - Mali: Telecel
      - Somalia: Hormuud Telecom
      - Guinea: Celcom

      We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted May 20, 2024 - 23:14 PDT
      Update
      We are continuing to experience SMS delivery delays to multiple networks and countries in Africa. Our engineers are working with our carrier partners to resolve the Incidents for each affected country.

      The following countries and respective network operators are impacted:
      - Guinea: MTN, Celcom
      - Mozambique: Vodacom
      - Tanzania: TTCL, Viettel

      We’re seeing recovery for these countries:
      - Uganda: MTN

      We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted May 20, 2024 - 08:04 PDT
      Update
      We continue to experience SMS delivery delays and failures to multiple networks and countries in Africa. Our engineers are working with our carrier partners to resolve the incidents. The following countries and respective network operators are impacted:

      - Guinea: MTN, Celcom
      - Mozambique: Vodacom
      - Uganda: MTN
      - Tanzania: TTCL, Viettel

      We’re seeing recovery for these countries:

      - Congo: Africell

      We expect to provide another update in 24 hours or as soon as more information becomes available.
      Posted May 19, 2024 - 09:26 PDT
      Update
      We are continuing to experience SMS delivery delays to multiple networks and countries in Africa. Our engineers are working with our carrier partners to resolve the incidents for each affected country. The following countries and respective network operators are impacted:

      - Guinea: MTN, Celcom
      - Mozambique: Vodacom
      - Uganda: MTN
      - Tanzania: TTCL, Viettel

      We’re seeing recovery for these countries:

      - Congo: Africell

      We expect to provide another update in 16 hours or as soon as more information becomes available.
      Posted May 18, 2024 - 17:26 PDT
      Update
      We are continuing to experience SMS delivery delays to multiple networks and countries in Africa. Our engineers are working with our carrier partners to resolve the incidents for each affected country. The following countries and respective network operators are impacted:

      - Guinea: MTN, Celcom
      - Mozambique: Vodacom
      - Uganda: MTN
      - Tanzania: TTCL, Viettel

      We’re seeing recovery for these countries:

      - Congo: Africell

      We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted May 18, 2024 - 09:26 PDT
      Update
      We are continuing to experience SMS delivery delays to multiple networks and countries in Africa. Our engineers are working with our carrier partners to resolve the incidents in each affected country. We expect to provide another update in 8 hours or as soon as more information becomes available.

      The following countries and respective network operators are impacted:

      - Congo: Africell
      - Guinea: MTN, Celcom
      - Mozambique: Vodacom
      - Tanzania: TTCL

      We’re seeing recovery for these countries:

      - Burundi: Viettel
      - Zambia: MTN
      Posted May 18, 2024 - 07:11 PDT
      Update
      We are continuing to experience SMS delivery delays to multiple networks and countries in Africa. Our engineers are working with our carrier partners to resolve the incidents in each affected country. We expect to provide another update in 4 hours or as soon as more information becomes available.

      The following countries and respective network operators are impacted:

      - Congo: Africell
      - Guinea: MTN, Celcom
      - Mozambique: Vodacom
      - Tanzania: TTCL

      We’re seeing recovery for these countries:

      - Burundi: Viettel
      - Zambia: MTN
      Posted May 18, 2024 - 03:10 PDT
      Update
      We are continuing to experience SMS delivery delays to multiple networks and countries in Africa. Our engineers are working with our carrier partners to resolve the incidents in each affected country. We expect to provide another update in 2 hours or as soon as more information becomes available.

      The following countries and respective network operators are impacted:

      - Congo: Africell
      - Guinea: MTN, Celcom
      - Mozambique: Vodacom
      - Tanzania: TTCL

      We’re seeing recovery for these countries:

      - Burundi: Viettel
      - Zambia: MTN
      Posted May 18, 2024 - 01:15 PDT
      Investigating
      We are continuing to experience SMS delivery delays to multiple networks and countries in Africa. Our engineers are working with our carrier partners to resolve the incidents in each affected country. We expect to provide another update in 1 hour or as soon as more information becomes available.

      The following countries and respective network operators are impacted:

      - Congo: Africell
      - Guinea: MTN, Celcom
      - Mozambique: Vodacom
      - Tanzania: TTCL

      We’re seeing recovery for these countries:

      - Burundi: Viettel
      - Zambia: MTN
      Posted May 18, 2024 - 00:19 PDT
      Monitoring
      We are observing successful SMS delivery to Multiple Networks and Countries in Africa. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted May 17, 2024 - 22:29 PDT
      Update
      We are continuing to experience SMS delivery delays to Multiple Networks and Countries in Africa. Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:

      - Congo: Africell
      - Guinea: MTN, Celcom
      - Mozambique: Vodacom
      - Tanzania: TTCL
      - Zambia: MTN

      We're seeing recovery for these countries:
      - Burundi: Viettel
      Posted May 17, 2024 - 16:27 PDT
      Update
      We are continuing to experience SMS delivery delays to Multiple Networks and Countries in Africa. Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:

      - Burundi: Viettel
      - Guinea: MTN, Celcom
      - Mozambique: Vodacom
      - Tanzania: TTCL
      - Zambia: MTN

      We're seeing recovery for these countries:
      - Gabon: Airtel
      - Malawi: TNM
      - Uganda: Smart

      We will provide an update in 24 hours or as soon as more information becomes available.
      Posted May 16, 2024 - 16:29 PDT
      Update
      We are continuing to experience SMS delivery delays to Multiple Networks and Countries in Africa. Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:

      - Burundi: Viettel
      - Gabon: Airtel
      - Guinea: MTN, Celcom
      - Malawi: TNM
      - Mozambique: Vodacom
      - Uganda: Smart
      - Zambia: MTN

      We're seeing recovery for these countries:
      - Algeria: Mobilis
      - Egypt: Etisalat

      We will provide an update in 24 hours or as soon as more information becomes available.
      Posted May 16, 2024 - 08:05 PDT
      Update
      We are continuing to experience SMS delivery delays to Multiple Networks and Countries in Africa. Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:

      - Algeria: Mobilis
      - Burundi: Viettel
      - Egypt: Etisalat
      - Gabon: Airtel
      - Guinea: MTN, Celcom
      - Malawi: TNM
      - Mozambique: Vodacom
      - Uganda: Smart
      - Zambia: MTN

      We're seeing recovery for these countries:
      - Tanzania: Vodacom, TTCL
      - Zimbabwe: Econet

      We will provide an update in 24 hours or as soon as more information becomes available.
      Posted May 15, 2024 - 23:43 PDT
      Update
      We are continuing to experience SMS delivery delays to Multiple Networks and Countries in Africa. Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:

      - Algeria: Mobilis
      - Burundi: Viettel
      - Egypt: Etisalat
      - Gabon: Airtel
      - Guinea: MTN, Celcom
      - Malawi: TNM
      - Mozambique: Vodacom
      - Tanzania: Vodacom, TTCL
      - Uganda: Smart
      - Zambia: MTN
      - Zimbabwe: Econet

      We will provide an update in 16 hours or as soon as more information becomes available.
      Posted May 15, 2024 - 12:47 PDT
      Update
      We are continuing to experience SMS delivery delays to Multiple Networks and Countries in Africa.
      Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:

      - Tanzania: Viettel, TTCL
      - Algeria: Mobilis
      - Ivory Coast: MTN
      - Guinea: Celcom
      - Burundi: Viettel
      - Libya: Al Madar

      We will provide an update in 16 hours or as soon as more information becomes available.
      Posted May 15, 2024 - 09:13 PDT
      Update
      We are continuing to experience SMS delivery delays to Multiple Networks and Countries in Africa.
      Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:
      - Tanzania: Viettel, TTCL
      - Algeria: Mobilis
      - Ivory Coast: MTN
      - Guinea: Celcom
      - Burundi: Viettel
      - Libya: Al Madar

      We will provide an update in 8 hours or as soon as more information becomes available.
      Posted May 15, 2024 - 01:27 PDT
      Update
      We are experiencing SMS delivery delays to Multiple Networks and Countries in Africa.
      Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:
      - Tanzania: Viettel, TTCL
      - Algeria: Mobilis
      - Ivory Coast: MTN
      - Guinea: Celcom
      - Burundi: Viettel
      - Libya: Al Madar

      The other African countries previously on the list has recovered. We will provide an update in 4 hour or as soon as more information becomes available.
      Posted May 14, 2024 - 21:27 PDT
      Update
      We are experiencing SMS delivery delays to Multiple Networks and Countries in Africa. We’re consolidating the following StatusPage posts:

      - https://status.twilio.com/incidents/sl3604fh5y9m
      - https://status.twilio.com/incidents/xkcftt6qq288
      - https://status.twilio.com/incidents/71llhjd20ydw
      - https://status.twilio.com/incidents/gpfqptn1p2tr
      - https://status.twilio.com/incidents/mrcx76lgqbg0

      Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:

      - Nigeria: 9mobile
      - Tanzania: Viettel, TTCL
      - South Africa: Rain
      - Kenya: Telkom
      - Uganda: Smart
      - Algeria: Mobilis
      - Mozambique: Movitel, Vodacom, MCEl
      - Ivory Coast: MTN
      - Niger: Orange
      - Mali: Orange
      - Burkina Faso: Orange
      - Malawi: Airtel
      - Senegal: Expresso
      - Guinea: Celcom
      - Burundi: Viettel, Telecel
      - Libya: Al Madar
      - Gabon: Airtel
      - Seychelles: Airtel

      We will provide an update in 4 hour or as soon as more information becomes available.
      Posted May 14, 2024 - 20:44 PDT
      Update
      We are experiencing SMS delivery delays to Multiple Networks and Countries in Africa. We’re consolidating the following StatusPage posts:

      - https://status.twilio.com/incidents/sl3604fh5y9m
      - https://status.twilio.com/incidents/xkcftt6qq288
      - https://status.twilio.com/incidents/71llhjd20ydw
      - https://status.twilio.com/incidents/gpfqptn1p2tr
      - https://status.twilio.com/incidents/mrcx76lgqbg0

      Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:

      - Nigeria: 9mobile
      - Tanzania: Viettel, TTCL
      - South Africa: Rain
      - Kenya: Telkom
      - Uganda: Smart
      - Algeria: Mobilis
      - Mozambique: Movitel, Vodacom, MCEl
      - Ivory Coast: MTN
      - Niger: Orange
      - Mali: Orange
      - Burkina Faso: Orange
      - Malawi: Airtel
      - Senegal: Expresso
      - Guinea: Celcom
      - Burundi: Viettel, Telecel
      - Libya: Al Madar
      - Gabon: Airtel
      - Seychelles: Airtel

      We will provide an update in 2 hour or as soon as more information becomes available.
      Posted May 14, 2024 - 18:56 PDT
      Update
      We are experiencing SMS delivery delays to Multiple Networks and Countries in Africa. We’re consolidating the following StatusPage posts:

      - https://status.twilio.com/incidents/sl3604fh5y9m
      - https://status.twilio.com/incidents/xkcftt6qq288
      - https://status.twilio.com/incidents/71llhjd20ydw
      - https://status.twilio.com/incidents/gpfqptn1p2tr
      - https://status.twilio.com/incidents/mrcx76lgqbg0

      Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. The following Countries and respective Network Operators are impacted:

      - Nigeria: 9mobile
      - Tanzania: Viettel, TTCL
      - South Africa: Rain
      - Kenya: Telkom
      - Uganda: Smart
      - Algeria: Mobilis
      - Mozambique: Movitel, Vodacom, MCEl
      - Ivory Coast: MTN
      - Niger: Orange
      - Mali: Orange
      - Burkina Faso: Orange
      - Malawi: Airtel
      - Senegal: Expresso
      - Guinea: Celcom
      - Burundi: Viettel, Telecel
      - Libya: Al Madar
      - Gabon: Airtel
      - Seychelles: Airtel

      We will provide an update in 1 hour or as soon as more information becomes available.
      Posted May 14, 2024 - 17:58 PDT
      Investigating
      We are experiencing SMS delivery delays to Multiple Networks and Countries in Africa. Our engineers are working with our carrier partners to resolve the Incidents for each affected Country. We will provide an update in 1 hour or as soon as more information becomes available.
      Posted May 14, 2024 - 17:35 PDT
      This incident affects: CARRIER NETWORK (SMS, Middle East & Africa).