Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delay to Google Voice Network in US Over a Subset of Short Code
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to Google Voice Network in US over a subset of Short Code. This incident has been resolved.
      Posted Jun 19, 2024 - 22:17 PDT
      Update
      We are observing recovery in SMS delivery delays when sending messages to Google Voice Network in US Over a Subset of Short Code. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 19, 2024 - 20:29 PDT
      Monitoring
      We are observing recovery in SMS delivery delays when sending messages to Google Voice Network in US Over a Subset of Short Code. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 19, 2024 - 20:25 PDT
      Update
      We are experiencing SMS delivery delays when sending messages to Google Voice Network in US Over a Subset of Short Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 19, 2024 - 19:48 PDT
      Update
      We are experiencing SMS delivery delays when sending messages to Google Voice Network in US Over a Subset of Short Code. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 19, 2024 - 19:48 PDT
      Investigating
      Our monitoring systems have detected a potential issue with SMS Delivery Delay to Google Voice Network in US over a subset of Short Code. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Jun 19, 2024 - 19:40 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).