Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays in A2P 10DLC T-Mobile Registrations and De-Registrations
      Incident Report for Twilio
      Update
      Our engineering team confirmed that they are seeing recovery on the A2P 10DLC T-Mobile Registrations and De-Registrations. We are nearly back to normal provisioning time. We will continue to monitor the current queue time, and work to resolve any numbers that had provisioning issues during this degradation. We will provide an update in 24 hours or as soon as more information becomes available.
      Posted May 04, 2024 - 14:59 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations are still working on the fix. The carrier has deployed several changes over the past few days. While we are still seeing higher than normal provisioning times and timeouts while provisioning, we are seeing improvements. We will provide updates in 24 hours or as soon as more information becomes available.
      Posted May 03, 2024 - 14:49 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations are still working on the fix. The carrier has deployed several changes over the past few days. While we are still seeing higher than normal provisioning times and timeouts while provisioning, we are seeing improvements. We will provide updates in 24 hours or as soon as more information becomes available.
      Posted May 02, 2024 - 14:50 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations and are continuing to work on the fix. The carrier has deployed several changes over the past few days. While we are still seeing higher than normal provisioning times and timeouts while provisioning, we are seeing improvements. We will provide updates in 24 hours or as soon as more information becomes available.
      Posted May 01, 2024 - 14:50 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations and are still working on the fix. The carrier has deployed several changes over the past few days. While we are still seeing higher than normal provisioning times and timeouts while provisioning, we are seeing improvements. We will provide updates in 24 hours or as soon as more information becomes available.
      Posted Apr 30, 2024 - 14:48 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations and are still working on the fix. We will provide updates in 24 hours or as soon as more information becomes available.
      Posted Apr 29, 2024 - 14:49 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations and are still working on the fix. We will provide updates in 24 hours or as soon as more information becomes available.
      Posted Apr 28, 2024 - 14:49 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations. We will provide updates in 24 hours or as soon as more information becomes available.
      Posted Apr 27, 2024 - 17:22 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations. We will provide updates in 24 hours or as soon as more information becomes available.
      Posted Apr 26, 2024 - 17:21 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations. We will provide updates in 24 hours or as soon as more information becomes available.
      Posted Apr 25, 2024 - 17:20 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations. We will provide updates in 16 hours or as soon as more information becomes available.
      Posted Apr 25, 2024 - 01:17 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations. We will provide updates in 8 hours or as soon as more information becomes available.
      Posted Apr 24, 2024 - 17:21 PDT
      Update
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations. We will provide updates in 4 hours or as soon as more information becomes available.
      Posted Apr 24, 2024 - 13:20 PDT
      Identified
      Our engineers have identified the issues causing delays in A2P 10DLC T-Mobile Registrations and De-Registrations. We will provide updates in 2 hours or as soon as more information becomes available.
      Posted Apr 24, 2024 - 11:20 PDT
      Update
      We are continuing our investigation and have discovered Programmable Messaging - SMS is affected by delays in A2P 10DLC T-Mobile Registrations and De-Registrations.
      Posted Apr 24, 2024 - 09:26 PDT
      Investigating
      Our monitoring systems have identified potential delays in A2P 10DLC T-Mobile Registrations and De-Registrations. Our engineering team has been notified and is currently investigating the issue. We will provide updates in 1 hour or as soon as more information becomes available.
      Posted Apr 24, 2024 - 09:18 PDT
      This incident affects: PROGRAMMABLE MESSAGING (SMS).