Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Afghanistan Roshan Network
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery delays to Afghanistan Roshan network. This incident has been resolved.
      Posted Aug 05, 2020 - 00:33 PDT
      Monitoring
      We are experiencing SMS delivery delays when sending messages to Afghanistan, specifically the Roshan Telecom Development Company Afghanistan Ltd. network. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Aug 04, 2020 - 23:46 PDT
      Update
      We are observing delays in SMS delivery to Afghanistan, specifically the Roshan Telecom Development Company Afghanistan Ltd. network. Our engineering team is working with our carrier partner to resolve the issue. We will offer an additional update in the next four hours.
      Posted Aug 04, 2020 - 19:43 PDT
      Update
      We are observing delays in SMS delivery to Afghanistan, specifically the Roshan Telecom Development Company Afghanistan Ltd. network. Our engineering team is working with our carrier partner to resolve the issue. We will offer an additional update in the next four hours.
      Posted Aug 04, 2020 - 15:43 PDT
      Update
      We are observing delays in SMS delivery to Afghanistan, specifically the Roshan Telecom Development Company Afghanistan Ltd. network. Our engineering team is working with our carrier partner to resolve the issue. We will offer an additional update in the next two hours.
      Posted Aug 04, 2020 - 13:45 PDT
      Investigating
      Our monitoring systems have detected a potential issue in SMS delivery delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Aug 04, 2020 - 13:31 PDT