Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to Umniah Network in Jordan
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Nov 28, 2022 - 15:31 PST
      Monitoring
      We have begun to observe recovery with SMS delivery delays when sending messages to Umniah Network in Jordan. We will continue to monitor the issue, and provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 28, 2022 - 14:25 PST
      Update
      We continue experiencing SMS delivery delays when sending messages to Umniah Network in Jordan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Nov 28, 2022 - 11:45 PST
      Update
      We are still experiencing SMS delivery delays when sending messages to Umniah Network in Jordan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Nov 28, 2022 - 07:44 PST
      Update
      We continue to experience SMS delivery delays when sending messages to Umniah Network in Jordan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 28, 2022 - 05:44 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to Umniah Network in Jordan. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Nov 28, 2022 - 04:51 PST
      This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).