Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Super SIM Connectivity Issues
      Incident Report for Twilio
      Resolved
      We are no longer experiencing any issue with Super SIM connectivity. This incident has been resolved.
      Posted Aug 04, 2022 - 17:10 PDT
      Monitoring
      We are now seeing recovery in Super SIM connectivity. We are continuing to monitor for service stability. We will provide another update in 2 hours or sooner once more information becomes available.
      Posted Aug 04, 2022 - 15:07 PDT
      Investigating
      We are experiencing Super SIM connectivity issues. Our engineering team is actively working with the affected network provider to resolve the issue. We will provide another update in 1 hour or sooner once more information becomes available.
      Posted Aug 04, 2022 - 14:08 PDT
      This incident affected: INTERNET OF THINGS (Super SIM).