Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to MTN Network In Ethiopia
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS/SMS delivery delays when sending messages to MTN network in Ethiopia. This incident has been resolved.
      Posted Feb 06, 2023 - 00:45 PST
      Monitoring
      We have observed a recovery from the SMS delivery delays when sending messages to the MTN network in Ethiopia. We are monitoring the service to ensure a full recovery, and we will provide another update in 2 hours or as soon as more information becomes available.
      Posted Feb 05, 2023 - 22:47 PST
      Update
      We are still experiencing SMS delivery delays when sending messages to the MTN network in Ethiopia. Our engineers are still working with our carrier partner to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Feb 05, 2023 - 21:30 PST
      Update
      We are still experiencing SMS delivery delays when sending messages to MTN network in Ethiopia. Our engineers are still working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Feb 05, 2023 - 17:38 PST
      Update
      We are continuing experiencing SMS delivery delays when sending messages to MTN network in Ethiopia. Our engineers are still working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Feb 05, 2023 - 15:40 PST
      Investigating
      We are experiencing SMS delivery delays when sending messages to MTN network in Ethiopia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Feb 05, 2023 - 14:46 PST