Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Failures on Digitel Venezuela
      Incident Report for Twilio
      Resolved
      We are no longer experiencing delivery failures to Digitel Venezuela. This incident has been resolved.
      Posted Jul 22, 2020 - 00:01 PDT
      Update
      We are still continuing to monitor to ensure a full recovery.
      Posted Jul 21, 2020 - 23:32 PDT
      Monitoring
      We are observing successful SMS delivery to Digitel Venezuela. We will continue to monitor to ensure a full recovery.
      Posted Jul 21, 2020 - 21:09 PDT
      Investigating
      We are experiencing delivery failures when sending messages to Digitel Venezuela. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Jul 21, 2020 - 20:09 PDT
      This incident affected: CARRIER NETWORK (SMS, Latin America).