Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Subset of Twilio WhatsApp Messages are Delayed
Incident Report for Twilio
Resolved
We have resolved the issue of WhatsApp messages being delayed.
Posted Jul 01, 2020 - 16:36 PDT
Monitoring
Delivery delays are no longer being observed for the impacted Twilio WhatsApp phone numbers. Our team is continuing to monitor and we will provide an update as soon as possible.
Posted Jul 01, 2020 - 16:03 PDT
Identified
We have identified the cause of the WhatsApp message delays, and have also identified that a subset of the queued messages may have failed. Our engineers are working to resolve this issue and we will provide additional updates as soon as possible.
Posted Jul 01, 2020 - 15:41 PDT
Update
We are continuing to investigate this issue.
Posted Jul 01, 2020 - 14:04 PDT
Update
A subset of Twilio WhatsApp numbers continue to experience delays when sending messages. We continue to investigate and will provide updates as more information becomes available.
Posted Jul 01, 2020 - 13:44 PDT
Investigating
A subset of Twilio WhatsApp phone numbers are experiencing delays when sending messages. Impacted messages will be queued before being sent. Our team is investigating the issue and we will provide an update as soon as we have more information.
Posted Jul 01, 2020 - 12:45 PDT
This incident affected: PROGRAMMABLE MESSAGING (Channels, Conversations).