Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Latency of Message Delivery on WhatsApp Channel for a Subset of Customers
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery delays when sending WhatsApp media messages. This incident has been resolved.
Posted Apr 22, 2021 - 14:40 PDT
Monitoring
We are observing recovery in WhatsApp media message delivery delays. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 minutes or as soon as more information becomes available.
Posted Apr 22, 2021 - 13:15 PDT
Update
We continue to investigate latency of message delivery on WhatsApp channel in Programmable Messaging for a subset of customers. The public facing Messaging API is fully operational, however with some WhatsApp media messages experiencing a delay. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Apr 22, 2021 - 09:43 PDT
Update
We continue to investigate latency of message delivery on WhatsApp channel in Programmable Messaging for a subset of customers. The public facing Messaging API is fully operational, however with some WhatsApp media messages experiencing a delay. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 22, 2021 - 07:44 PDT
Update
We are investigating latency of message delivery on WhatsApp channel in Programmable Messaging for a subset of customers. The public facing API is fully operational, but the delivery receipts are delayed. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 22, 2021 - 06:44 PDT
Investigating
Our monitoring systems have detected a potential issue with messages delayed on WhatsApp channel for programmable SMS. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Apr 22, 2021 - 06:24 PDT
This incident affected: PROGRAMMABLE MESSAGING (Messaging Channels).