Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Calls failing to some Twilio Israel phone numbers
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Jun 25, 2019 - 02:54 PDT
      Monitoring
      We are currently observing a recovery for calling Twilio phone numbers in Israel. Our teams continue to monitor the service and will provide an update as soon as we have more information.
      Posted Jun 25, 2019 - 02:20 PDT
      Investigating
      Calls to some Twilio phone numbers in Israel are failing. Our engineers are working with our carrier partner to resolve this issue and will provide more information as soon as available.
      Posted Jun 25, 2019 - 01:31 PDT
      This incident affected: CARRIER NETWORK (Voice, Middle East & Africa).