Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Issue Affecting Hosting of Toll-Free Numbers
      Incident Report for Twilio
      Resolved
      We are no longer experiencing issues with carrier uploads failing for hosted number orders. This incident has been resolved.
      Posted Apr 13, 2024 - 02:13 PDT
      Update
      We are still continuing to investigate carrier upload failing for Hosted Number orders. Our engineers are working to resolve the issue. We will provide another update in 8 hours or as soon as more information becomes available.
      Posted Apr 12, 2024 - 18:58 PDT
      Update
      We are continuing to investigate carrier upload failing for Hosted Number orders. Our engineers are working to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted Apr 12, 2024 - 15:26 PDT
      Update
      We are continuing to investigate carrier upload failing for Hosted Number orders. Our engineers are working to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Apr 12, 2024 - 13:07 PDT
      Investigating
      We are investigating carrier upload failing for Hosted Number orders. We expect to provide another update in 1 hour or as soon as more information becomes available
      Posted Apr 12, 2024 - 12:06 PDT
      This incident affected: PHONE NUMBERS.