Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delay to Peru
      Incident Report for Twilio
      Resolved
      The issue affecting message delays to a subset of Twilio Peru Movistar Phone Numbers has been resolved, and the service is functioning normally at this time.
      Posted Nov 24, 2021 - 16:03 PST
      Monitoring
      We are observing successful SMS delivery from Peru Movistar phone numbers in the last 30 minutes. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 24, 2021 - 14:32 PST
      Update
      Our monitoring systems have detected a potential issue impacting receiving messages from Peru Movistar. Our engineers have been alerted and are actively investigating. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Nov 24, 2021 - 12:49 PST
      Investigating
      We've become aware of a potential issue with SMS delivery delays to Peru. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Nov 24, 2021 - 12:02 PST
      This incident affected: PROGRAMMABLE MESSAGING (SMS).