Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Call failures on inbound calls to landline numbers in Mexico
      Incident Report for Twilio
      Resolved
      Our carrier partner has resolved the issue and inbound calls to landline numbers in Mexico are operating normally at this time.
      Posted May 14, 2016 - 05:03 PDT
      Update
      Our carrier partner has confirmed the issue. We are continuing to work with them on a resolution.
      Posted May 14, 2016 - 03:14 PDT
      Investigating
      We are experiencing high percentage of inbound call failures to landline numbers in Mexico. We have escalated the issue to our local carrier partner.
      Posted May 14, 2016 - 02:04 PDT
      This incident affected: PHONE NUMBERS.