Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Twilio IoT & KORE Account Linking Links Expiring
      Incident Report for Twilio
      Resolved
      We have deployed a fix that will correctly generate a valid link visiting "Link a KORE Account" page. If you were previously blocked due to having an expired link, please try clicking the button in the Twilio Console to create your KORE account again to go to KORE and complete the account linking process.
      Posted Jun 05, 2023 - 14:30 PDT
      Identified
      If you previously viewed the "Link a KORE Account" page in Internet of Things section of the Twilio Console, but did not complete the process within 24 hours of first viewing the page, the link to that takes you to the KORE Console to create your account will have expired and no longer be valid. Our team has identified the issue and is actively working to resolve it. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jun 05, 2023 - 13:19 PDT
      Investigating
      If you previously viewed the "Link a KORE Account" page in Internet of Things section of the Twilio Console but did not complete the process within 24 hours of first viewing the page, the link to that takes you to the KORE Console to create your account will have expired and no longer be valid. Our team is investigating how to allow you to get a refreshed link so you can complete the account linking process. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted Jun 05, 2023 - 12:19 PDT