Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Delays over Subset of Short Codes to Multiple Networks in the U.S.
Incident Report for Twilio
Resolved
We are no longer experiencing MMS delivery delays over short codes when sending messages to carriers in the United States. This incident has been resolved.
Posted Jul 14, 2021 - 13:49 PDT
Monitoring
We are observing recovery in MMS delivery delays over a subset of short codes to multiple carriers in the United States. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Jul 14, 2021 - 11:59 PDT
Investigating
We are experiencing MMS delivery delays over a subset of short codes to multiple carriers in the United States. Our engineers are working with our carrier partners to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 14, 2021 - 11:07 PDT
This incident affected: CARRIER NETWORK (MMS Short Code, North America).