Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS, MMS and WhatsApp Logging Delays For Inbound and Outbound Traffic In Console and API
Incident Report for Twilio
Resolved
We are resolving this incident on StatusPage as customers are no longer experiencing message log and media delays using Twilio Console and API. Please note that the work to update message price info is still ongoing, with an estimated completion date of Sep 13th. If the ETA changes, we will provide an update on StatusPage with a new incident.
Posted Sep 07, 2021 - 16:49 PDT
Monitoring
The backlog has been cleared, and we are continuing to monitor the overall stability of the service. At this point customers are no longer experiencing message log and media delays using Twilio Console and API. As mentioned previously, message price delays would take longer to resolve. We will provide an update in 24 hours or as soon as more information becomes available.
Posted Sep 06, 2021 - 21:39 PDT
Update
We are at the last stage in completely catching up on the backlog to resolve message log and media delays using Twilio Console and API. We expect message price delays to take longer to resolve. We will provide an update in 24 hours or as soon as more information becomes available.
Posted Sep 06, 2021 - 12:45 PDT
Update
Our engineers continue to make steady progress in resuming our processing speed to clear the backlog, while we monitor the overall stability of the service. Until the backlog is cleared, customers may experience message log delays, media and message price retrieval failures. We will provide an update in 24 hours or as soon as more information becomes available.
Posted Sep 05, 2021 - 12:47 PDT
Update
The first stage fix is now in place. Our engineers are gradually increasing the processing speed to ensure the overall stability of the service while we catch up on backlog processing. Until the backlog is cleared, we expect the impact of the incident continues to surface in the following ways: 
- SMS, MMS and WhatsApp log delays for inbound and outbound traffic using Console UI or Twilio API. Messages may not be available for querying, or message records may not be updated after initial creation for hours.
- Media retrieval failures for MMS and WhatsApp messages due to processing delays. Customers may experience “No Media Available” error when attempting to retrieve a media resource.
- Message price info retrieval failure.
We will provide an update in 24 hours or as soon as more information becomes available.
Posted Sep 04, 2021 - 12:48 PDT
Update
Our engineers continue to make progress with our first stage fix targeted for Sep 4. Currently the impact of the incident is manifested in the following ways:
- SMS, MMS and WhatsApp log delays for inbound and outbound traffic using Console UI or Twilio API. Messages may not be available for querying, or message records may not be updated after initial creation for hours.
- Media retrieval failures for MMS and WhatsApp messages due to processing delays. Customers may experience “No Media Available” error when attempting to retrieve a media resource.
- Message price info retrieval failure.
Please note that webhooks are not impacted by this incident. We will provide an update in 24 hours or as soon as more information becomes available.
Posted Sep 03, 2021 - 12:46 PDT
Update
Our engineers have been alerted that customers are likely to experience SMS, MMS and WhatsApp log delays for inbound and outbound traffic when using Console UI or Twilio API. Our engineers are working on the fix with an ETA for the first stage of the fix of 09/04. Once we successfully deploy the first stage we will determine the ETA for resolving the backlog and final resolution. We will provide an update in 24 hours or as soon as more information becomes available.
Posted Sep 02, 2021 - 19:09 PDT
Update
Our engineers have been alerted that customers are likely to experience SMS, MMS and WhatsApp log delays for inbound and outbound traffic when using Console UI or Twilio API. Our engineers are working on the fix with an ETA for the first stage of the fix of 09/04. Once we successfully deploy the first stage we will determine the ETA for resolving the backlog and final resolution. We will provide an update in 24 hours or as soon as more information becomes available.
Posted Sep 02, 2021 - 14:36 PDT
Update
Our engineers have been alerted that customers are likely to experience SMS, MMS and WhatsApp log delays for inbound and outbound traffic when using Console UI or Twilio API. Our engineers are working on the fix with an ETA for the first stage of the fix of 09/04. Once we successfully deploy the first stage we will determine the ETA for resolving the backlog and final resolution. We will provide an update in 24 hours or as soon as more information becomes available.
Posted Sep 01, 2021 - 14:34 PDT
Identified
Our engineers have been alerted that customers are likely to experience SMS, MMS and WhatsApp log delays for inbound and outbound traffic when using Console UI or Twilio API. Our engineers are working on the fix with an ETA for the first stage of the fix of 09/04, we will provide an update in 24 hours or as soon as more information becomes available.
Posted Aug 31, 2021 - 14:38 PDT
Update
We are still observing recovery in SMS, MMS and WhatsApp log delays for inbound and outbound traffic when using Console UI or Twilio API. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Aug 31, 2021 - 14:19 PDT
Update
We are still observing recovery in SMS, MMS and WhatsApp log delays for inbound and outbound traffic when using Console UI or Twilio API. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Aug 31, 2021 - 12:12 PDT
Update
We are still observing recovery in SMS, MMS and WhatsApp log delays for inbound and outbound traffic when using Console UI or Twilio API. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Aug 31, 2021 - 10:20 PDT
Monitoring
We are observing recovery in SMS, MMS and WhatsApp log delays for inbound and outbound traffic when using Console UI or Twilio API. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Aug 31, 2021 - 08:30 PDT
Update
Our engineers have been alerted that customers are likely to experience SMS, MMS and WhatsApp log delays for inbound and outbound traffic when using Console UI or Twilio API. Our engineers are working on the fix with an ETA for the first stage of the fix of 09/04, we will provide an update in 4 hours or as soon as more information becomes available.
Posted Aug 31, 2021 - 04:39 PDT
Update
Our engineers have been alerted that customers are likely to experience SMS, MMS and WhatsApp log delays for inbound and outbound traffic when using Console UI or Twilio API. Our engineers are working on the fix with an ETA for the first stage of the fix of 09/04, we will provide an update in 2 hours or as soon as more information becomes available.
Posted Aug 31, 2021 - 02:38 PDT
Update
Our engineers have been alerted that customers are likely to experience SMS logs delays when using Console UI or Twilio API. Our engineers are working on the fix with an ETA for the first stage of the fix of 09/04, we will provide an update in 1 hour or as soon as more information becomes available.
Posted Aug 31, 2021 - 01:33 PDT
Investigating
Our monitoring systems have detected a potential issue with SMS Message Logging Delays. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Aug 30, 2021 - 23:54 PDT
This incident affected: PROGRAMMABLE MESSAGING (MMS, SMS, Messaging Channels).