Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Inbound Call Failures Affecting Subset of North American Phone Numbers
Incident Report for Twilio
Resolved
The issue affecting inbound calls to Twilio California Phone Numbers has been resolved, and the service is functioning normally at this time.
Posted Jul 22, 2020 - 15:06 PDT
Monitoring
We have started seeing recovery for inbound calls to Twilio California Phone Numbers for the last 20 minutes. We will continue to monitor to ensure a full recovery.
Posted Jul 22, 2020 - 14:51 PDT
Identified
We have identified that the issue with inbound call failures has impacted a subset of California Phone Numbers. We are actively working with our carrier partner to resolve the issue. We will provide an update as soon as more information becomes available.
Posted Jul 22, 2020 - 14:38 PDT
Update
We are observing call failures to a subset of Twilio North American phone numbers. We are currently working with our carrier partner to resolve the issue. We will provide an update as soon as more information becomes available.
Posted Jul 22, 2020 - 13:52 PDT
Investigating
Our monitoring systems have detected a potential issue affecting inbound calls to some Twilio numbers. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 22, 2020 - 13:29 PDT
This incident affected: PROGRAMMABLE VOICE (PSTN) and CARRIER NETWORK (Voice, North America).