Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Report Delays to US Via Short Codes
      Incident Report for Twilio
      Resolved
      We have fully investigated the MMS delivery reports issues to USA to multiple Networks via subset of short codes, and it was determined that the impact was limited to a small set of customers, who have been contacted individually to address any concerns. All systems are operational.
      Posted May 10, 2022 - 08:52 PDT
      Investigating
      We are experiencing MMS delivery reports to USA to multiple Networks via subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted May 10, 2022 - 08:36 PDT
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).