Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Call Quality Issues to a subset of Twilio's Numbers in Multiple Countries (Puerto Rico, Mexico, United States)
      Incident Report for Twilio
      Resolved
      Call quality to a subset of Twilio's numbers in Multiple Countries (Puerto Rico, Mexico, United States) is now operating normally.
      Posted Dec 17, 2024 - 13:27 PST
      Monitoring
      Call quality to a subset of Twilio's numbers in Multiple Countries (Puerto Rico, Mexico, United States) is now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
      Posted Dec 17, 2024 - 11:34 PST
      Update
      Our engineers have identified a call quality issue to a subset of Twilio's numbers in Multiple Countries (Puerto Rico, Mexico, United States). We are working to deploy a fix. We expect to provide another update in 2 hours or as soon as more information becomes available
      Posted Dec 17, 2024 - 09:36 PST
      Investigating
      Our engineers have identified the issue with call quality issue to a subset of Twilio's numbers in Puerto Rico. We are working to deploy a fix. We expect to provide another update in 1 hour or as soon as more information becomes available
      Posted Dec 17, 2024 - 08:51 PST
      This incident affected: PROGRAMMABLE VOICE (PSTN).