Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delay To Indosat Indonesia
Incident Report for Twilio
Resolved
We are no longer experiencing any delays to Indosat in Indonesia. The incident has been resolved.
Posted Jul 09, 2020 - 01:28 PDT
Monitoring
We see a decrease in the number of delayed messages and a stabilization in the service to this provider.
Posted Jul 09, 2020 - 00:40 PDT
Update
We are continuing to work with our carrier partner to resolve the issue. We will provide further updates as more information becomes available.
Posted Jul 08, 2020 - 23:24 PDT
Investigating
We are experiencing SMS delivery delays to the Indosat network in Indonesia. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jul 08, 2020 - 22:28 PDT
This incident affected: CARRIER NETWORK (SMS, APAC).