Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Flex Insights Historical Reporting Delayed for a Small Subset of Customers
Incident Report for Twilio
Resolved
Flex Insights experienced 50 min delay in processing data for a small subset of customers. The data were about conversations between agents and customers in Historical part of reporting. No data were lost, all the historical data were available to the customers. The delay is now mitigated, all the data are available.
Posted Jul 21, 2020 - 09:59 PDT
Update
We are continuing to investigate this issue.
Posted Jul 21, 2020 - 09:26 PDT
Investigating
Our monitoring systems have detected a potential issue. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Jul 21, 2020 - 09:09 PDT
This incident affected: FLEX (Flex Insights).