Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Twilio Verify Logs are not Viewable in the Console for a Subset of Customers
Incident Report for Twilio
Resolved
The Issue affecting Twilio Verify logs has been resolved and the product is operating normally at this time.
Posted Mar 24, 2021 - 16:34 PDT
Monitoring
Twilio Verify Logs are now operating normally. We will continue to monitor for system stability. We'll provide another update in 30 minutes or as soon as more information becomes available.
Posted Mar 24, 2021 - 16:06 PDT
Update
We are addressing the issue where Twilio Verify API logs are not viewable in the console for a small number of our customers. We expect to provide another update in one hour or as soon as more information becomes available.
Posted Mar 24, 2021 - 15:38 PDT
Investigating
Our monitoring systems have detected a potential issue with Twilio Verify. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Mar 24, 2021 - 15:14 PDT
This incident affected: ACCOUNT SECURITY (Verify).