Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound Message Delivery Failures to a Subset of Phone Numbers in the Philippines
      Incident Report for Twilio
      Resolved
      We are no longer experiencing inbound message delivery failures to a subset of Twilio Philippine Phone Numbers. This incident has been resolved.
      Posted May 20, 2022 - 05:46 PDT
      Monitoring
      We have started seeing recovery for the issue causing inbound message delivery failures to a subset of Twilio Philippine Phone Numbers.. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted May 20, 2022 - 03:49 PDT
      Update
      We are experiencing inbound message delivery failures to a subset of Twilio Philippine Phone Numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 20, 2022 - 01:55 PDT
      Investigating
      We are experiencing inbound message delivery failures to a subset of Twilio Philippine Phone Numbers. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 20, 2022 - 00:58 PDT
      This incident affected: CARRIER NETWORK (SMS, APAC).