Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Inbound Calls Failing to a subset of Mexico phone numbers from Guadalajara and Mexico City
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Apr 08, 2020 - 07:59 PDT
      Investigating
      We are experiencing a subset of calls failing intermittently to a subset of Twilio Mexico DIDs for Guadalajara (+5233, +5232) and Mexico city region (+5255). Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Apr 08, 2020 - 01:50 PDT
      This incident affected: CARRIER NETWORK (Voice, Latin America).