Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Elevated SMS delays from US Short codes to Verizon handsets
Incident Report for Twilio
Resolved
All systems are operating normally.
Posted 4 months ago. Oct 10, 2018 - 17:27 PDT
Monitoring
The issue causing delays between US Short codes and Verizon handsets has been resolved and all messages are now being delivered successfully. We will continue to monitor to ensure full resolution.
Posted 4 months ago. Oct 10, 2018 - 16:20 PDT
Investigating
We are observing up to 30 min delays between Short codes and Verizon numbers. We are working with our partners to get the issue resolved.
Posted 4 months ago. Oct 10, 2018 - 15:58 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America) and PROGRAMMABLE MESSAGING (SMS).