Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays for a subset of Twilio Short Codes to Small Regional US Carriers
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Mar 26, 2020 - 22:17 PDT
Monitoring
We are observing successful SMS delivery for US short codes to small regional US carriers. We will continue to monitor to ensure a full recovery.
Posted Mar 26, 2020 - 22:03 PDT
Update
We further checked that we are experiencing SMS delivery delays when sending messages to small regional US carriers with a subset of Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.

Please refer below list of carriers:
RINA
Union Wireless
West Central Wireless
Bluegrass Cellular
Illinois Valley Cellular
Inland Cellular
Nex Tech Communications
Limitless Mobile (formerly Immix)
Cellcom
Cellular One of East Central Illinois (ECIT) - DECOMMISSIONED
Alaska Communications Systems (ACS)
GCI Comm
(General Communications Inc. in AK)
Thumb Cellular
Chat Mobility
NW Missouri Cellular
Panhandle Wireless (aka PTCI)
Viaero Wireless
MTPCS Cellular One (aka Cellone Nation)
Duet IP
SouthernLinc
SRT Communications
Copper Valley Telecom
Mid-Rivers Communications
Carolina West
ASTAC (Arctic Slope Telephone Cooperative Association)
Cordova Telephone Cooperative Inc dba Cordova Wireless
Pine Belt
Shelcomm, Inc.
Standing Rock
Posted Mar 26, 2020 - 21:14 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to NewCell in the USA with a subset of Twilio Short Codes. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Mar 26, 2020 - 20:05 PDT
This incident affected: CARRIER NETWORK (SMS Short Code, North America).