Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS delivery delays to Asia Cell in Iraq
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays when sending to Iraq Asia Cell. This incident has been resolved.
Posted Jun 16, 2020 - 01:10 PDT
Monitoring
We are no longer observing SMS delivery delays to AsiaCell Iraq. We will continue to monitor to ensure a full recovery.
Posted Jun 16, 2020 - 00:16 PDT
Update
We are continuing to experience SMS delivery delays on a subset of messages sent to Asia Cell Telecommunications in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 15, 2020 - 21:11 PDT
Update
We are continuing to experience SMS delivery delays on a subset of messages sent to Asia Cell Telecommunications in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 14, 2020 - 21:15 PDT
Update
We are continuing to experience SMS delivery delays on a subset of messages sent to Asia Cell Telecommunications in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 13, 2020 - 09:02 PDT
Update
We are continuing to experience SMS delivery delays on a subset of messages sent to Asia Cell Telecommunications in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 12, 2020 - 17:11 PDT
Update
We are continuing to experience SMS delivery delays when sending messages to Asia Cell Telecommunications in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 12, 2020 - 08:56 PDT
Update
We are continuing to experience SMS delivery delays when sending messages to Asia Cell Telecommunications in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 12, 2020 - 00:30 PDT
Update
We are continuing to experience SMS delivery delays when sending messages to Asia Cell Telecommunications in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 11, 2020 - 20:38 PDT
Update
We are continuing to experience SMS delivery delays when sending messages to Asia Cell Telecommunications in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 11, 2020 - 14:27 PDT
Update
We are continuing to experience SMS delivery delays when sending messages to Asia Cell Telecommunications in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 11, 2020 - 12:24 PDT
Update
We are experiencing SMS delivery delays when sending messages to Asia Cell Telecommunications in Iraq. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 11, 2020 - 10:34 PDT
Update
We are continuing to investigate this issue.
Posted Jun 11, 2020 - 10:33 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to Asia Cell Telecommunications. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted Jun 11, 2020 - 10:28 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).