We are no longer experiencing SMS delivery delays when sending messages from Twilio to Algar Telecom network subscribers in Brazil. This incident has been resolved.
Posted Feb 22, 2026 - 12:27 PST
Monitoring
We have observed a recovery in SMS delivery from Twilio to Algar Telecom network subscribers in Brazil and are monitoring service stability. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 22, 2026 - 11:43 PST
Update
Twilio customers may be experiencing SMS delivery delays from Twilio to Algar Telecom network subscribers in Brazil. Our team is actively investigating this issue. We will provide another update in 8 hours or as soon as more information becomes available.
Posted Feb 22, 2026 - 04:25 PST
Update
Twilio customers may be experiencing SMS delivery delays from Twilio to Algar Telecom network subscribers in Brazil. Our team is actively investigating this issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Feb 22, 2026 - 00:31 PST
Update
Twilio customers may be experiencing SMS delivery delays from Twilio to Algar Telecom network subscribers in Brazil. Our team is actively investigating this issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 21, 2026 - 22:45 PST
Investigating
Twilio customers may be experiencing SMS delivery delays from Twilio to Algar Telecom network subscribers in Brazil. Our team is actively investigating this issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 21, 2026 - 21:52 PST
This incident affected: CARRIER NETWORK (SMS, Latin America).