Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Degradation Towards AT&T in Mexico
Incident Report for Twilio
Resolved
AT&T has reported the issue is resolved and message delivery to Mexico is no longer experiencing delay.
Posted Nov 20, 2019 - 15:38 PST
Investigating
AT&T is currently experiencing a service disruption in Mexico which is causing delayed message delivery to all destinations in Mexico. AT&T is actively working towards a solution. We will provide an update shortly.
Posted Nov 20, 2019 - 14:11 PST
This incident affected: CARRIER NETWORK (SMS, Latin America).