Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays to Claro Domincan Republic
Incident Report for Twilio
Resolved
We are no longer experiencing delivery failures when sending messages to Claro Dominican Republic. This incident has been resolved.
Posted Feb 10, 2021 - 12:59 PST
Monitoring
We are observing an improvement on SMS Delivery to Claro Domincan Republic. Our engineers are monitoring the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 10, 2021 - 11:32 PST
Update
We are continuing experiencing SMS delivery delays when sending messages to Claro Domincan Republic. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
Posted Feb 10, 2021 - 09:40 PST
Update
We are continuing experiencing SMS delivery delays when sending messages to Claro Domincan Republic. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 10, 2021 - 08:35 PST
Update
We are continuing experiencing SMS delivery delays when sending messages to Claro Domincan Republic. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
Posted Feb 10, 2021 - 07:40 PST
Investigating
We are experiencing SMS delivery delays when sending messages to Claro Domincan Republic. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Feb 10, 2021 - 06:40 PST
This incident affected: CARRIER NETWORK (SMS, Latin America).