Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
MMS Delivery Receipt Delays to US Handsets
Incident Report for Twilio
Resolved
The delayed delivery report issue which affected MMS sent from and to US shortcodes and long codes is now resolved. MMS delivery is now operating normally
Posted about 1 month ago. Mar 18, 2019 - 01:03 PDT
Investigating
We are experiencing delays in delivery receipts for outbound MMS messages sent to US mobile devices over some long codes and short codes. We are working with our carrier partners to resolve this issue. We will provide more information as soon as available
Posted about 1 month ago. Mar 17, 2019 - 17:22 PDT
This incident affected: CARRIER NETWORK (MMS Long Code, North America, MMS Short Code, North America).