Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Outbound SMS in Kenya
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Feb 14, 2020 - 12:52 PST
Identified
Our team has detected a network issue preventing the delivery of outbound SMS in Kenya. We'll work with our carrier partners to resolve the issue and update this status as needed.
Posted Feb 14, 2020 - 12:16 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).