Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Carriers around the world are experiencing capacity issues because of increased demand on their networks due to COVID-19. This may result in voice quality issues, busy signals, or other errors on your phone calls. Twilio continues to monitor the health of the global carrier networks and we are publishing the most up-to-date information on our Worldwide Telephony Network Congestion page.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Errors when attempting to retrieve step logs for new Execution Steps in Studio
Incident Report for Twilio
Resolved
Our engineers have implemented a fix. We are no longer experiencing issues with Studio. This incident has been resolved.
Posted Mar 17, 2020 - 23:53 PDT
Identified
Our engineers have implemented a fix and we are seeing signs of recovery. They are continuing to work on it to get full recovery. We will provide an update as soon as we have additional information.
Posted Mar 17, 2020 - 23:28 PDT
Investigating
We are observing errors when attempting to retrieve step logs for new Execution Steps in Studio. Our engineers are currently investigating this issue. We will provide an update as soon as we have additional information.
Posted Mar 17, 2020 - 22:48 PDT
This incident affected: SERVERLESS (Studio).