Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery Delays to US Over a Subset of Short Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing SMS delivery delays when sending messages to the US over a subset of short codes. This incident has been resolved.
      Posted May 27, 2022 - 08:25 PDT
      Update
      We are observing recovery in SMS delivery delays when sending messages to the US over a subset of short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 27, 2022 - 06:49 PDT
      Investigating
      We are experiencing SMS delivery delays when sending messages to US (311-180)numbers over a subset of short codes.. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 27, 2022 - 05:51 PDT
      This incident affected: CARRIER NETWORK (SMS Short Code, North America).