Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Wireless SIM Activities Delayed
Incident Report for Twilio
Resolved
All Wireless systems are now operating as designed.
Posted 22 days ago. Jan 27, 2019 - 08:59 PST
Investigating
T-Mobile USA is is currently experiencing issues executing SIM activities. As such, SIM lifecycle activities (activation, suspension, Rate Plan changes, etc) are currently being accepted in the `scheduled` state, and will be automatically queued and actioned at a later time when the service is restored. We will provide additional information as quickly as possible.
Posted 22 days ago. Jan 27, 2019 - 00:24 PST
This incident affected: PROGRAMMABLE WIRELESS.