Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delay To Bmobile in Trinidad and Tobago
Incident Report for Twilio
Resolved
The issue is now resolved and the service is back to normal delivery.
Posted May 11, 2020 - 18:43 PDT
Monitoring
We are observing recovery to Bmobile and messages are delivered with no delay. We will keep monitoring the traffic and confirm the final solution soon.
Posted May 11, 2020 - 18:09 PDT
Investigating
We are experiencing SMS delivery delay when sending messages to the Bmobile network in Trinidad and Tobago. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
Posted May 11, 2020 - 17:06 PDT
This incident affected: CARRIER NETWORK (SMS, Latin America).