Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS delivery delays and non-deliveries to Multiple MTN Networks across African countries
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Jan 19, 2020 - 17:59 PST
      Monitoring
      We are observing recovery in message delivery delays and non-deliveries towards the MTN network. Our team is continuously monitoring the service and will provide an update as soon as we have more information
      Posted Jan 19, 2020 - 17:04 PST
      Investigating
      We are observing message delivery delays and non-deliveries towards the MTN network in African countries. At the moment this issue is affecting the following countries: Nigeria, Ghana, Rwanda, Cameroon, Benin, Uganda and Sudan. MTN have identified the issue and are working towards restoring service as soon as possible. We will provide an update as soon as we have additional information or updates.
      Posted Jan 19, 2020 - 14:24 PST