Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Receipt Delays to Multiple Networks in the U.S. from a Subset of Short Codes
      Incident Report for Twilio
      Resolved
      We are no longer experiencing MMS delivery receipt delays when sending messages to multiple networks in the United States from a subset of short codes. This incident has been resolved.
      Posted May 24, 2024 - 16:51 PDT
      Monitoring
      We are observing recovery in MMS delivery receipt delays when sending messages to multiple networks in the United States from a subset of short codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 24, 2024 - 15:00 PDT
      Update
      We continue to experience MMS delivery receipt delays when sending messages to multiple networks in the United States from a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 4 hours or as soon as more information becomes available.
      Posted May 24, 2024 - 11:33 PDT
      Update
      We continue to experience MMS delivery receipt delays when sending messages to multiple networks in the United States from a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted May 24, 2024 - 09:33 PDT
      Investigating
      We are experiencing MMS delivery receipt delays when sending messages to multiple networks in the United States from a subset of short codes. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
      Posted May 24, 2024 - 08:33 PDT
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).