Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays From and To Multiple Networks in the US via Twilio Toll Free Number
Incident Report for Twilio
Resolved
SMS delivery was degraded for 45 minutes between 20:30 and 21:15 Pacific Time on 07/14/2021. During this period, customers may have experienced SMS delivery delays when sending and receiving messages to Multiple Networks in the US via Twilio Toll Free Number. The issue has now been resolved.
Posted Jul 14, 2021 - 21:26 PDT
Identified
We are experiencing SMS delivery delays when sending and receiving messages to Multiple Networks in the US via Twilio Toll Free Number. This is Identified as an Emergency Maintenance by our Carrier partner. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jul 14, 2021 - 21:10 PDT
This incident affected: CARRIER NETWORK (SMS Long Code, North America).