Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS not being delivered to Airtel Nigeria
Incident Report for Twilio
Resolved
SMS delivery failures to Airtel Nigeria has been resolved and is operating normally at this time.
Posted 20 days ago. Jan 29, 2019 - 17:04 PST
Identified
We are have identified SMS delivery failures to customers on the Airtel network in Nigeria. We are working with our carrier partners to resolve the issue.
Posted 20 days ago. Jan 29, 2019 - 15:59 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).