Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Delays with SMS Status Callbacks
      Incident Report for Twilio
      Resolved
      We have resolved the issue with delayed SMS status callbacks. We are currently replaying any affected message status callbacks.
      Posted Mar 14, 2016 - 13:25 PDT
      Investigating
      We are investigating delays with SMS status callbacks. Some messages may appear to remain in ‘Sent’ state.
      Posted Mar 14, 2016 - 13:01 PDT