Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Twilio Account Creation and Updates
      Incident Report for Twilio
      Resolved
      We are no longer experiencing issue with Twilio account creation and updates. This incident has been resolved.
      Posted Apr 10, 2024 - 20:34 PDT
      Monitoring
      We are observing recovery in Twilio account creation and updates. We will continue monitoring the service to ensure a full recovery. We will provide another update in 30 mins or as soon as more information becomes available.
      Posted Apr 10, 2024 - 20:04 PDT
      Identified
      Our engineers have identified an issue with Twilio account creation and updates. We expect to provide another update in 1hr or as soon as more information becomes available.
      Posted Apr 10, 2024 - 19:56 PDT
      This incident affected: TWILIO PLATFORM (Other).