Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      SMS Delivery delays and possible delivery failures to mCell in Mozambique
      Incident Report for Twilio
      Resolved
      Unfortunately the mCell Mozambique network is still intermittently unresponsive, we will provide an information when we receive confirmation from our partner that the issue has been fixed
      Posted Mar 03, 2020 - 08:13 PST
      Update
      The cause of SMS delivery issues to mCell network in Mozambique has been identified. The end network is still intermittently unresponsive. Our partners are working on restoring the traffic. We will share more updates as soon as we have additional information.
      Posted Mar 02, 2020 - 19:34 PST
      Update
      The cause of SMS delivery issues to mCell network in Mozambique has been identified. The end network is still intermittently unresponsive. Our partners are working on restoring the traffic. We will share more updates as soon as we have additional information.
      Posted Mar 02, 2020 - 15:44 PST
      Update
      The cause of SMS delivery issues to mCell network in Mozambique has been identified. The end network is still intermittently unresponsive.
      Our partners are working on restoring the traffic. We will share more updates as soon as we have additional information.
      Posted Mar 02, 2020 - 09:54 PST
      Update
      The cause of SMS delivery issues to mCell network in Mozambique has been identified. The end network is intermittently unresponsive.
      Our partners are working on restoring the traffic. We will share more updates as soon as we have additional information.
      Posted Mar 02, 2020 - 09:08 PST
      Update
      The cause of SMS delivery issues to mCell network in Mozambique has been identified. The issues are due to the fact that the end network is intermittently unresponsive.
      Our partners are working on restoring the traffic. We will share more updates as soon as we have additional information.
      Posted Mar 02, 2020 - 03:25 PST
      Update
      Our engineers and the carrier teams have identified the cause of SMS delivery issues to mCell network in Mozambique. The issues are due to the fact that the end network is intermittently unresponsive.
      Our partners are working on restoring the traffic. We will share more updates as soon as we have additional information.
      Posted Mar 01, 2020 - 22:02 PST
      Update
      Our engineers and the carrier teams have identified the cause of SMS delivery issues to mCell network in Mozambique. The issues are due to the fact that the end network is intermittently unresponsive.
      Our partners are working on restoring the traffic. We will share more updates as soon as we have additional information.
      Posted Mar 01, 2020 - 17:03 PST
      Update
      Our engineers and the carrier teams have identified the cause of SMS delivery issues to mCell network in Mozambique. The issues are due to the fact that the end network is intermittently unresponsive.
      Our partners are working on restoring the traffic. We will share more updates as soon as we have additional information.
      Posted Mar 01, 2020 - 13:02 PST
      Update
      Our engineers and the carrier teams have identified the cause of SMS delivery issues to mCell network in Mozambique. The issues are due to the fact that the end network is intermittently unresponsive.
      Our partners are working on restoring the traffic. We will share more updates as soon as we have additional information.
      Posted Mar 01, 2020 - 09:02 PST
      Identified
      Our engineers and the carrier teams have identified the cause of SMS delivery issues to mCell network in Mozambique. The issues are due to the fact that the end network is intermittently unresponsive.
      Our partners are working on restoring the traffic. We will share more updates as soon as we have additional information.
      Posted Mar 01, 2020 - 04:14 PST
      Update
      Our engineers and the carrier teams are continuing to investigate SMS delivery issues to mCell network in Mozambique. The issue is most likely due to the end operator experiencing intermittent downtimes.
      We will share more updates as soon as they become available.
      Posted Mar 01, 2020 - 03:21 PST
      Update
      Our engineers are still investigating SMS delivery issues when sending messages to mCell network in Mozambique with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 29, 2020 - 21:12 PST
      Update
      Our engineers are still investigating SMS delivery issues when sending messages to mCell network in Mozambique with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 29, 2020 - 17:11 PST
      Update
      Our engineers are still investigating SMS delivery issues when sending messages to mCell network in Mozambique with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 29, 2020 - 13:35 PST
      Update
      Our engineers are still investigating SMS delivery issues when sending messages to mCell network in Mozambique with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 29, 2020 - 09:47 PST
      Update
      Our engineers are still investigating SMS delivery issues when sending messages to mCell network in Mozambique with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 29, 2020 - 05:45 PST
      Update
      Our engineers are still investigating SMS delivery issues when sending messages to mCell network in Mozambique with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 29, 2020 - 01:55 PST
      Update
      Our engineers are still investigating SMS delivery issues when sending messages to mCell network in Mozambique with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 28, 2020 - 21:54 PST
      Update
      Our engineers are still investigating SMS delivery issues when sending messages to mCell network in Mozambique with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 28, 2020 - 17:47 PST
      Update
      Our engineers are still investigating SMS delivery issues when sending messages to mCell network in Mozambique with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 28, 2020 - 12:11 PST
      Update
      Our engineers are still investigating this issue with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 28, 2020 - 08:14 PST
      Update
      Our engineers are still investigating this issue with the underlying carrier. We will share more updates as soon as they become available.
      Posted Feb 28, 2020 - 04:22 PST
      Investigating
      We are experiencing SMS delivery issues when sending messages to mCell network in Mozambique. Our engineers are working with our carrier partner to resolve the issue. We will provide an update as soon as we have additional information.
      Posted Feb 28, 2020 - 02:34 PST