Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delay to Telesom Somalia
Incident Report for Twilio
Resolved
We are no longer experiencing SMS delivery failures to SMS Delivery Delay to Telesom Somalia. This incident has been resolved.
Posted Apr 02, 2021 - 17:56 PDT
Monitoring
We are observing improvements in stability with SMS delivery to Telesom Somalia. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 02, 2021 - 15:49 PDT
Investigating
We are experiencing SMS delivery delays when sending messages to Telesom Somalia. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Apr 02, 2021 - 14:30 PDT
Monitoring
We are observing improvements to the SMS delivery delays to Telesom Somalia. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Apr 02, 2021 - 13:53 PDT
Update
Our engineering team has been alerted and is actively investigating. We will provide further updates in 1 hour or as soon as we have more information
Posted Apr 02, 2021 - 12:53 PDT
Investigating
Our monitoring systems have detected a potential issue with SMS delivery delay to Telesom Somalia. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
Posted Apr 02, 2021 - 12:50 PDT
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa, SMS Delivery Notifications & Status Callbacks).