Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING CARRIER MAINTENANCE
External carriers notify us when they are conducting maintenance.
Subscribe for updates so you’ll know ahead of time about their potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
Degraded Performance with Subscribing to StatusPage Updates
Incident Report for Twilio
Resolved
This incident has been resolved.
Posted Oct 29, 2019 - 10:55 PDT
Investigating
We are currently seeing degraded performance with subscribing to StatusPage updates. Customers will not be able to subscribe to updates through SMS, E-mail, or through Webhook. Our engineering team is looking into the issue.
Posted Oct 29, 2019 - 10:50 PDT
This incident affected: TWILIO PLATFORM (Other).