Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      Failures To Access API GET List For Account AvailablePhoneNumber TollFree
      Incident Report for Twilio
      Resolved
      All services impacted by an issue with Twilio Rest API have recovered and are operating as intended. This incident has been resolved.
      Posted Sep 15, 2023 - 19:19 PDT
      Monitoring
      We are experiencing failures to access GET API List for Account, AvailablePhoneNumber and TollFree is now operating normally. We will continue to monitor for system stability. We'll provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 15, 2023 - 17:21 PDT
      Update
      1. inventory-search-service (the service used to look up the numbers in Elastic Search) is returning some numbers that are not present inventory_dids_to_did_tags table. This seems to be related to an onboarding issue with a subset of tollfree numbers.
      This is causing as to use our fallback and go to the database. This is happening for most tollfree requests to the available phone numbers page.
      2. When the pageSize is set in the request, the query issued to the database is faster than when the pageSize is not included. That's why the issue only shows up for the requests without a pageSize.

      We expect to provide another update in 8 hours or as soon as more information becomes available.
      Posted Sep 15, 2023 - 16:28 PDT
      Identified
      Our engineers have identified the issue with the AvailablePhoneNumbers/TollFree api returning 500 errors and are working to deploy a fix. As a workaround please include a PageSize parameter in your requests at this time. We expect to provide another update in 4 hours or as soon as more information becomes available.
      Posted Sep 15, 2023 - 14:26 PDT
      Update
      We are experiencing failures to access GET API List for Account, AvailablePhoneNumber and TollFree. Our engineering team has been alerted and is actively investigating. We expect to provide another update in 2 hours or as soon as more information becomes available.
      Posted Sep 15, 2023 - 13:00 PDT
      Update
      We are experiencing failures to access GET API List for Account, AvailablePhoneNumber and TollFree. Our engineering team has been alerted and is actively investigating. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Sep 15, 2023 - 12:03 PDT
      Investigating
      Our monitoring systems have detected a potential issue with access GET API List for Account, AvailablePhoneNumber and TollFree. Our engineering team has been alerted and is actively investigating. We will update as soon as we have more information.
      Posted Sep 15, 2023 - 11:47 PDT
      This incident affected: PHONE NUMBERS.