Twilio Services
Issues related to Twilio’s Software
    External Connectivity
    Issues found outside of Twilio’s Network
      Scheduled maintenance
      System Metrics
      MMS Delivery Delays to US Carriers From a Small Subset of Short-Codes
      Incident Report for Twilio
      Resolved
      This incident has been resolved.
      Posted Jan 21, 2023 - 15:12 PST
      Monitoring
      We are observing recovery in MMS delivery delays when sending messages to US Carriers from a small subset of Short-Codes. We will continue monitoring the service to ensure a full recovery. We will provide another update in 2 hours or as soon as more information becomes available.
      Posted Jan 21, 2023 - 13:20 PST
      Update
      We continue to experience MMS delivery delays to US Carriers from a small subset of Short-Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hour or as soon as more information becomes available.
      Posted Jan 21, 2023 - 12:40 PST
      Investigating
      We are experiencing MMS delivery delays to US Carriers from a small subset of Short-Codes. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 1 hour or as soon as more information becomes available.
      Posted Jan 21, 2023 - 11:42 PST
      This incident affected: CARRIER NETWORK (MMS Short Code, North America).