Twilio Status Page
Check here for updates about Twilio’s service availability and the status of telecom carriers globally.
Subscribe to get real-time updates via email, RSS, Slack, and more.
Twilio Services
Issues related to Twilio’s Software
External Connectivity
Issues found outside of Twilio’s Network
MAINTENANCE UPDATE NOTIFICATIONS
UPCOMING MAINTENANCE
External carriers often notify us when they will be conducting maintenance.
Subscribe for updates so you’ll know ahead of time about potential service disruptions.
SYSTEM METRICS
Stay up to date on the speed at which you connect.
Know more, so you can do more.
SMS Delivery Delays When Sending Messages to Egypt Vodafone Network
Incident Report for Twilio
Resolved
We are no longer experiencing delivery delays to Egypt Vodafone Network. This incident has been resolved.
Posted Jan 14, 2021 - 10:22 PST
Update
We continue to see recovery in SMS Delivery Delays when sending messages to Egypt Vodafone Network. In order to ensure a full recovery we are waiting for confirmation from our carrier partner that the root cause has been fully addressed. We will have another update in 8 hours or as soon as more information becomes available.
Posted Jan 14, 2021 - 09:08 PST
Update
We continue to see recovery in SMS Delivery Delays when sending messages to Egypt Vodafone Network. In order to ensure a full recovery we are waiting for confirmation from our carrier partner that the root cause has been fully addressed. We will have another update in 16 hours or as soon as more information becomes available.
Posted Jan 14, 2021 - 09:06 PST
Update
We continue to see recovery in SMS Delivery Delays when sending messages to Egypt Vodafone Network. In order to ensure a full recovery we are waiting for confirmation from our carrier partner that the root cause has been fully addressed. We will have another update in 8 hours or as soon as more information becomes available.
Posted Jan 14, 2021 - 01:08 PST
Monitoring
We continue to see recovery in SMS Delivery Delays when sending messages to Egypt Vodafone Network. In order to ensure a full recovery we are waiting for confirmation from our carrier partner that the root cause has been fully addressed. We will have another update in 8 hours or as soon as more information becomes available.
Posted Jan 13, 2021 - 17:08 PST
Identified
Our engineers continue to work with our carrier partner to ensure that the intermittent delivery delays for SMS towards Vodafone network are resolved. We expect to provide an update in 16 hours or as soon as more information becomes available.
Posted Jan 13, 2021 - 15:01 PST
Monitoring
We are no longer experiencing SMS delivery delays when sending messages to Egypt Vodafone Network. We will continue to monitor to ensure a full recovery. We will have another update in 2 hours or as soon as more information is available.
Posted Jan 13, 2021 - 12:51 PST
Identified
After investigation, our carrier partner has confirmed that a hardware issue on their network is currently resulting in reduced capacity for message processing, resulting in intermittent delivery delays for SMS towards Vodafone network, we will continue to work with our partner to resolve this issue, we expect to provide an update in 8 hours or as soon as more information becomes available.
Posted Jan 13, 2021 - 04:44 PST
Update
We continue to work with our carrier partner to resolve the issue of SMS delivery delays when sending messages to Egypt Vodafone Network. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 13, 2021 - 01:36 PST
Investigating
We are once again observing SMS delivery delays when sending messages to Egypt Vodafone Network. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 12, 2021 - 23:38 PST
Update
We are observing a recovery in SMS delivery delays to Egypt Vodafone Network. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 12, 2021 - 22:27 PST
Monitoring
We are observing a recovery in SMS delivery delays to Egypt Vodafone Network. We will continue to monitor to ensure full service recovery. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 12, 2021 - 20:24 PST
Investigating
We are once again observing SMS delivery delays when sending messages to Egypt Vodafone Network. Our engineers are working with our carrier partner to resolve the issue. We expect to provide another update in 4 hours or as soon as more information becomes available.
Posted Jan 12, 2021 - 16:27 PST
Monitoring
We are observing a recovery in SMS delivery delays to Egypt Vodafone Network for the passed 1 hour. We will continue to monitor to ensure full service recovery. We expect to provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 12, 2021 - 14:20 PST
Update
We continue to work with our carrier partner to resolve the issue of SMS delivery delays when sending messages to Egypt Vodafone Network. We expect to provide another update in 2 hours or as soon as more information becomes available.
Posted Jan 12, 2021 - 12:40 PST
Investigating
We are experiencing SMS delivery delays when sending messages to Egypt Vodafone Network. Our engineers are working with our carrier partner to resolve the issue. We will provide another update in 1 hour or as soon as more information becomes available.
Posted Jan 12, 2021 - 11:42 PST
This incident affected: CARRIER NETWORK (SMS, Middle East & Africa).